System Requirements

To get the best experience of WP Page Builder, we recommend you to have the following system requirements. If you are not sure whether you have the following system requirements, you can contact your hosting provider.

PHP

The minimum PHP version supported is PHP 5.6 but WP Page Builder works great with PHP v7.2 or greater (and it’s recommended to have the latest PHP version).

WordPress

You need to have a properly functional WordPress in your site in order to use WP Page Builder. We recommend having WordPress v4.5 or greater.

MySQL/MariaDB

For MySQL database, the minimum required version is 5.6 and for MariaDB database, the minimum required version is 10.0.

Browsers

WP Page Builder is tested on Chrome, Safari, and Firefox (we recommend using any of these browsers) and it works on Microsoft Edge and Opera too (may not have the best performance). Be assured, pages that are built with WP Page Builder will load on every browser.

Device

It is advised to use a desktop environment for development purpose. You will still be able to load WP Page Builder with small devices (mobiles & tablets) but please note, you cannot perform editing with WP Page Builder in mobile devices.

Servers

WP Page Builder can work on all the servers supporting PHP, MySQL and runs WordPress perfectly.